Scheduled Maintenance - FIBRE GEEKS - Bellville
Scheduled for 25 March, 2026 at 7:00 AM โย 5:00 PM
Affects
Fibre Geeks ๐ค
Under maintenance from 7:00 AM to 5:00 PM
Planned
25 March, 2026 at 5:00 PMPlanned
25 March, 2026 at 5:00 PMFIBRE GEEKS are conducting network maintenance in Brackenfell on Wednesday, 25th March 2026 from 09:00.
Nodes affected:
Services will be temporarily unavailable for roughly 10 hours during this interval.
Completed
25 March, 2026 at 5:00 PMCompleted
25 March, 2026 at 5:00 PMMaintenance has completed successfully
In progress
25 March, 2026 at 7:00 AMIn progress
25 March, 2026 at 7:00 AMMaintenance is now in progress