GetWiza - Service Outage - THINKSPEED (Century City) โ€“ Incident details

All systems operational

Service Outage - THINKSPEED (Century City)

Resolved
Partial outage
Started 8 months agoLasted about 3 hours

Affected

Thinkspeed ๐Ÿƒโ€โ™‚๏ธ

Partial outage from 9:59 AM to 1:00 PM

Updates
  • Resolved
    Resolved

    THINKSPEED have confirmed that services are once again operational. If you're still experiencing connectivity issues, please reach out to us on WhatsApp so that our support team can assist you.

  • Update
    Update

    THINKSPEED have identified the cause of the connectivity issue to be a fibre break. Their engineers are working on a temporary solution to restore connectivity on a backup link while the fibre repairs are underway. There is no ETR as yet, but we will continue to provide you with updates as they become available.

  • Investigating
    Investigating

    We've been notified of a fibre outage in Century City by THINKSPEED, our upstream provider, who is currently investigating. We'll provide updates as they become available.