GetWiza - Service Outage - Google & Spotify Services โ€“ Incident details

All systems operational

Service Outage - Google & Spotify Services

Resolved
Operational
Started over 2 years agoLasted about 4 hours
Updates
  • Resolved
    Resolved

    Engineers have resolved the fault.

  • Investigating
    Investigating

    Customers may experience connectivity issues to Google and/or Spotify services. Engineers are currently working on resolving the problem.