GetWiza - Service Outage - Fibre Geeks โ€“ Incident details

All systems operational

Service Outage - Fibre Geeks

Resolved
Operational
Started over 2 years agoLasted about 8 hours
Updates
  • Update
    Update

    The incident has been resolved

  • Update
    Update

    Fibre Geeks have identified a substantial fibre break. Teams have been dispatched to repair. Unfortunately no ETA is available at this stage.

  • Investigating
    Investigating

    We've been notified of an outage in the Koelenhof/Tweespruit area. Fibre Geeks technicians are attending. We'll provide updates as they become available.