Scheduled Maintenance - FIBRE GEEKS - Bellville
Scheduled for 20 April, 2026 at 5:00 PM โย 21 April, 2026 at 5:00 AM
Affects
Fibre Geeks ๐ค
Under maintenance from 5:00 PM to 5:00 AM
Completed
21 April, 2026 at 5:00 AMCompleted
21 April, 2026 at 5:00 AMMaintenance has completed successfully
In progress
20 April, 2026 at 5:00 PMIn progress
20 April, 2026 at 5:00 PMMaintenance is now in progress
Planned
20 April, 2026 at 5:00 PMPlanned
20 April, 2026 at 5:00 PMFIBRE GEEKS' backhaul fibre provider will be conducting network maintenance in Bellville on 20 April 2026 from 19:00.
Nodes affected:
Services will be temporarily unavailable for roughly 12 hours during this interval.