Scheduled for 19 March, 2026 at 7:00 PM โย 20 March, 2026 at 5:00 AM
Affects
Fibre Geeks ๐ค
Under maintenance from 7:00 PM to 5:00 AM
Updates
Completed
20 March, 2026 at 5:00 AM
Completed
20 March, 2026 at 5:00 AM
Maintenance has completed successfully
In progress
19 March, 2026 at 7:00 PM
In progress
19 March, 2026 at 7:00 PM
Maintenance is now in progress
Planned
19 March, 2026 at 7:00 PM
Planned
19 March, 2026 at 7:00 PM
FIBRE GEEKS have notified us that their backhaul provider will be conducting emergency network maintenance in Bellville this evening Thursday, 19 March 2026 from 21:00.
Nodes affected:
La Recolte Retirement Village
Services will be temporarily unavailable for roughly 10 hours during this interval.