Scheduled Maintenance - FIBRE GEEKS - Somerset West
Completed
Scheduled for 18 March, 2026 at 6:00 AM โย 11:00 AM
Affects
Fibre Geeks ๐ค
Under maintenance from 6:00 AM to 11:00 AM
Updates
Completed
18 March, 2026 at 11:00 AM
Completed
18 March, 2026 at 11:00 AM
Maintenance has completed successfully
In progress
18 March, 2026 at 6:00 AM
In progress
18 March, 2026 at 6:00 AM
Maintenance is now in progress
Planned
18 March, 2026 at 6:00 AM
Planned
18 March, 2026 at 6:00 AM
FIBRE GEEKS has notified us of scheduled electrical maintenance at Somerset Sereno and Somerset Place on Wednesday, 18 March 2026.
Backup power will remain active throughout the maintenance window, and no significant impact to connectivity is anticipated. However, customers who depend on stable connectivity are advised to consider making alternate arrangements during this time.
Duration: 5 hours Service impact: Minimal - no outages expected, though minor disruptions cannot be ruled out.