We are seeing client services restore. Should your connection not have restored, please reboot your router by disconnecting the power for 60 seconds. Should your internet still not restore, please contact us via WhatsApp on 0212044878
Update
Update
Fibre Geeks have identified the cause to be a faulty mains supply which tripped the UPS protection. The Fibre Geeks team are working to resolve ASAP.
Investigating
Investigating
Fibre Geeks have confirmed that there is a power fault affecting the Koelenhof area at the moment. Fibre Geeks are attending to the fault.