GetWiza - Service Outage - Stellenbosch โ€“ Incident details

All systems operational

Service Outage - Stellenbosch

Resolved
Operational
Started about 2 years agoLasted about 2 hours
Updates
  • Update
    Update

    The incident has been resolved

  • Update
    Update

    Fibre Geeks have resolved the power fault and services have restored.

  • Update
    Update

    Fibre Geeks technicians have confirmed that there is a power fault at their primary node. Technicians are investigating.

  • Investigating
    Investigating

    We are aware of a fibre outage affecting clients in the Stellenbosch area. We have logged a case with Fibre Geeks and will provide updates as they become available.