GetWiza - Service Outage - [FIBRE GEEKS] โ Incident details
All systems operational
Service Outage - [FIBRE GEEKS]
Resolved
Operational
Started about 3 years ago14 June, 2023Lasted about 2 hours14 June, 202311:55 AM1:28 PMUTC
Updates
Resolved
UTC
Resolved
UTC
Fibre Geeks have identified and resolved the fault.
Investigating
UTC
Investigating
UTC
We've been notified of an outage at Mooiberge Estate by our upstream provider, who is currently investigating.
We'll provide updates as they become available.